<!DOCTYPE html>
<html lang="en" dir="ltr">
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta property="keywords" content="News, government and politics,Rosemount, Rosemount Port Authority, Retail Strategies" />
<meta property="news_keywords" content="News, government and politics,Rosemount, Rosemount Port Authority, Retail Strategies" />
<meta property="author" content="Kara Hildreth" />
<meta property="description" content="Rosemount Port Authority debated the value of continuing to pay for the annual membership of Retail Strategies — a firm that assists cities in the pursuit..." />
<meta property="article:modified_time" content="2019-06-28T05:00:57-05:00" />
<meta property="article:published_time" content="2019-06-28T05:00:57-05:00" />
<meta property="fb:app_id" content="491045361015226" />
<meta property="og:url" content="https://www.farmingtonindependent.com/news/government-and-politics/4630378-rosemount-port-authority-debates-value-low-performing-retail" />
<meta property="twitter:url" content="https://www.farmingtonindependent.com/news/government-and-politics/4630378-rosemount-port-authority-debates-value-low-performing-retail" />
<meta property="twitter:image" content="https://www.farmingtonindependent.com/sites/default/files/styles/16x9_430/public/field/image/meeting%20watch_72.jpg?itok=bR59A84K" />
<meta property="twitter:description" content="Rosemount Port Authority debated the value of continuing to pay for the annual membership of Retail Strategies — a firm that assists cities in the pursuit of retail opportunities — at its June 18 meeting.The firm communicates to companies that may wish to locate or develop a new business or industry..." />
<meta property="article:tag" content="News, government and politics,Rosemount, Rosemount Port Authority, Retail Strategies" />
<meta property="article:publisher" content="https://www.facebook.com/farmingtonindependent" />
<meta property="og:type" content="article" />
<meta property="twitter:title" content="Rosemount Port Authority debates value of low performing Retail..." />
<meta property="twitter:card" content="summary_large_image" />
<meta property="og:title" content="Rosemount Port Authority debates value of low performing Retail..." />
<meta property="og:image:height" content="698" />
<meta property="og:description" content="Rosemount Port Authority debated the value of continuing to pay for the annual membership of Retail Strategies — a firm that assists cities in the pursuit of retail opportunities — at its June 18 meeting.The firm communicates to companies that may wish to locate or develop a new business or industry..." />
<meta property="og:image" content="https://www.farmingtonindependent.com/sites/default/files/styles/16x9_1240/public/field/image/meeting%20watch_72.jpg?itok=-hkfsmrA" />
<meta property="og:image:width" content="1240" />
<link rel="shortcut icon" href="https://www.farmingtonindependent.com/sites/all/themes/farmingtonindependent_theme/favicon.ico" type="image/x-icon" />
<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=2.0, minimum-scale=0.5, user-scalable=yes" />
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<link rel="apple-touch-icon" href="https://www.farmingtonindependent.com/sites/all/themes/farmingtonindependent_theme/images/touch-icon.png" type="image/png" />
<link rel="amphtml" href="https://www.farmingtonindependent.com/news/government-and-politics/4630378-rosemount-port-authority-debates-value-low-performing-retail?amp" />
<link rel="canonical" href="/news/government-and-politics/4630378-rosemount-port-authority-debates-value-low-performing-retail" />
<script type="application/javascript" src="https://content.jwplatform.com/libraries/R6N0vQlD.js" />
</script><link rel="shortlink" href="/node/4630378" />
<!-- Global site tag (gtag.js) - Google Analytics -->
      <script async src="https://www.googletagmanager.com/gtag/js?id=UA-778232-78" />
</script><script>window.dataLayer = window.dataLayer || [];
        function gtag(){dataLayer.push(arguments);}
        gtag('js', new Date());

        gtag('config', 'UA-778232-78');</script>
    <title>Rosemount Port Authority debates value of low performing Retail Strategies  | Farmington Independent</title>
    <link type="text/css" rel="stylesheet" href="https://www.farmingtonindependent.com/sites/default/files/css/css_rEI_5cK_B9hB4So2yZUtr5weuEV3heuAllCDE6XsIkI.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.farmingtonindependent.com/sites/default/files/css/css_s03_ouljUuspf04Mu33L4-w5-jjMVCPB0hfXbp6v04g.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.farmingtonindependent.com/sites/default/files/css/css_iBbIvnMu4nqg4ubyLxls3rCH2au4qZIYIR9bsfjZVGU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.farmingtonindependent.com/sites/default/files/css/css_dn1Z7ijuixoG-wMmyYi-2wgXq6gNxLsgC7vdi2dJMWs.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://unpkg.com/leaflet@1.0.3/dist/leaflet.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.farmingtonindependent.com/sites/default/files/css/css_-4S8c2jcxbs1gWpaJrWx2fB7l84-Ww7NRTVyxDCBH7I.css" media="all" />

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="https://www.farmingtonindependent.com/sites/default/files/css/css_cJsge75ubbR-lGzepYwLuU3Z8ch1IrsZDx5aSlDs__M.css" media="print" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="https://www.farmingtonindependent.com/sites/all/themes/fcc_basetheme/css/article-slider.css?ptakau" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="https://www.farmingtonindependent.com/sites/all/themes/fcc_basetheme/css/featherlight.min.css?ptakau" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.farmingtonindependent.com/sites/all/themes/farmingtonindependent_theme/css/global-no-mqs.css?ptakau" media="all" />
<![endif]-->

<!--[if gt IE 8]><!-->
<link type="text/css" rel="stylesheet" href="https://www.farmingtonindependent.com/sites/all/themes/farmingtonindependent_theme/css/global.css?ptakau" media="all" />
<!--<![endif]-->

<!--[if (lt IE 9)&(!IEMobile)]>
<link type="text/css" rel="stylesheet" href="https://www.farmingtonindependent.com/sites/default/files/css/css_h7dZJ4SGhBPblw5MFhWB5lEUUHZodCULH3O-ZXgVv0M.css" media="all" />
<![endif]-->

<!--[if gte IE 9]><!-->
<link type="text/css" rel="stylesheet" href="https://www.farmingtonindependent.com/sites/default/files/css/css_EFG_CH3uZ4YjwsKUY2BjPl69tPfMiB0UKmsKOzpXt5k.css" media="all" />
<!--<![endif]-->
<script type="text/javascript" src="https://www.farmingtonindependent.com/sites/default/files/js/js_oTw2mccdSyi5Mu_UeNjwZZ2nsxd4cA8KM0jkogZEw68.js"></script>
<script type="text/javascript" src="https://www.farmingtonindependent.com/sites/default/files/js/js_9xKWV5CISD-YBXQ1tn5i-yvPXYsen1swMNl0vfhq8nQ.js"></script>
<script type="text/javascript" src="https://www.farmingtonindependent.com/sites/default/files/js/js_qdYchoQ6U5cmg5dZ307qiUM03rDEOxZdegmqA8aPui8.js"></script>
<script type="text/javascript" src="https://www.farmingtonindependent.com/sites/default/files/js/js_tKYV-tUUZkCPmu0K-3gDno2p0xevGnewdyNIVGGcHaw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-778232-11', 'auto')
        ga('create', 'UA-41542537-2', 'fccnn.com', { 'name': 'combinedSites'});
        ga('require', 'linkid', 'linkid.js');
        ga('require', 'displayfeatures');
        ga('combinedSites.require', 'linkid', 'linkid.js');
        ga('combinedSites.require', 'displayfeatures');
        ga('set', 'dimension1', 'anonymous');
        var pixelRatio = (window.devicePixelRatio >= 1.5) ? 'HiDPI' : '1X';
        ga('set', 'dimension2', pixelRatio);
        ga('send', 'pageview');
        ga('combinedSites.send', 'pageview');
//--><!]]>
</script>
<script type="text/javascript" src="https://www.farmingtonindependent.com/sites/default/files/js/js_dw8vp3sZhDu3IiuuDl9okWDOmYLV7szkmH6QKmEisVg.js"></script>
<script type="text/javascript" src="https://unpkg.com/leaflet@1.0.3/dist/leaflet.js"></script>
<script type="text/javascript" src="https://api.fccinteractive.com/gmaps-kml-app/feeds/radar/js/min/radar.min.js"></script>
<script type="text/javascript" src="https://www.farmingtonindependent.com/sites/default/files/js/js_EbeHsjfK-XIt1JoIKq6Gqj3s12axNUs10_e3yFVNaUw.js"></script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56ca182d0de565d1&amp;async=1&amp;domready=1"></script>
<script type="text/javascript" src="https://www.farmingtonindependent.com/sites/all/modules/custom/fcc_advertising/prebid/jquery.lazyload.js?ptakau"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

        // Set Global Vars
        try {
          var dfp_keywords = "'News','government and politics','Rosemount','Rosemount Port Authority','Retail Strategies'";
          var zone = "farmingtonindependent";
        } catch (e) {
          console.log('Error setting up global vars', e);
        }
        // Load GPT asynchronously
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        (function(){
          var gads = document.createElement('script');
          gads.async = true;
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
        })();
//--><!]]>
</script>
<script type="text/javascript" src="https://www.farmingtonindependent.com/sites/all/modules/custom/fcc_advertising/prebid/prebid.min.js?ptakau"></script>
<script type="text/javascript" src="https://www.farmingtonindependent.com/sites/all/modules/custom/fcc_advertising/prebid/googletag-base-node.js?ptakau"></script>
<script type="text/javascript" src="https://www.farmingtonindependent.com/sites/default/files/js/js_4_LhLQ8kBLbt1AVlytvey9HpNGus6E72kfkXIbmtKRs.js"></script>
<script type="text/javascript" src="https://www.farmingtonindependent.com/sites/default/files/js/js_qpS3kGTqrFq13S5nzMYgDM_AvDfcQ8VncTTWcYuMbyg.js"></script>
<script type="text/javascript">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</script>
    <!--[if lt IE 9]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta http-equiv="X-UA-Compatible" content="IE=edge" /><!-- Google Tag Manager -->
<script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0];var j=d.createElement(s);var dl=l!='dataLayer'?'&l='+l:'';j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;j.type='text/javascript';j.async=true;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PF9F4L');</script>
<!-- End Google Tag Manager -->   </head>
  <body class="html not-front not-logged-in page-node page-node- page-node-4630378 node-type-article domain-www-farmingtonindependent-com context-news"><!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PF9F4L" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager -->
      <div id="skip-link">
          <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
      </div>
      <div class="region region-page-top" id="region-page-top">
  <div class="region-inner region-page-top-inner">
      </div>
</div><div class="page clearfix" id="page">
      <header id="section-header" class="section section-header">
    
  <div id="zone-top-leaderboard" class="zone zone-top-leaderboard clearfix container-16">
      </div>
<div id="zone-user-wrapper" class="zone-wrapper zone-user-wrapper clearfix">  
  <div id="zone-user" class="zone zone-user clearfix container-16">
    <div class="grid-5 region region-user-first fcc-omega-user-first first-omega-col" id="region-user-first">
  <div class="region-inner region-user-first-inner">
    <div  class="block block-menu block-menu-login block-menu-menu-login odd" id="block-menu-menu-login">
  <div class="block-inner clearfix">
    <div class="content clearfix">
                    <ul class="menu">
          <li class="first">
            <a href="/user" title="Login">Login</a>
          </li>
          <!--<li class="last">
            <a href="/register" title="Register">Register</a>
          </li>-->
        </ul>
          </div>
  </div>
</div>  </div>
</div><div class="grid-11 region region-user-second last-omega-col" id="region-user-second">
  <div class="region-inner region-user-second-inner">
    <div class="mobile-button-hq">Classifieds</div>
<div  class="block block-menu block-menu-hq-links block-menu-menu-hq-links odd" id="block-menu-menu-hq-links">
  <div class="block-inner clearfix">
    <div class="content clearfix">
      <ul class='menu'><li class='first leaf'><a href="http://www.carshq.com" title="CarsHQ">CarsHQ</a></li><li class='leaf'><a href="http://www.jobshq.com" title="JobsHQ">JobsHQ</a></li><li class='leaf'><a href="http://www.homeshq.com" title="HomesHQ">HomesHQ</a></li><li class='leaf'><a href="http://www.apartmentshq.com" title="ApartmentsHQ">ApartmentsHQ</a></li><li class='leaf'><a href="classifieds" title="Classifieds">Classifieds</a></li><li class='last leaf'><a href="https://searchmarketplaces.com/marketplace/farmingtonrosemounttownpages/" title="Marketplace: Farmington Independent &amp; Rosemount Town Pages">Marketplace</a></li></ul>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-branding-wrapper" class="zone-wrapper zone-branding-wrapper clearfix">  
  <div id="zone-branding" class="zone zone-branding clearfix container-16">
    <div class="grid-4 region region-branding fcc-omega-brand first-omega-col" id="region-branding">
  <div class="region-inner region-branding-inner">
        <div class="branding-data clearfix">
            <div class="logo-img">
        <a href="/" rel="home" title="Farmington Independent"><img src="https://www.farmingtonindependent.com/sites/all/themes/farmingtonindependent_theme/logo.png" alt="Farmington Independent" id="logo" /></a>      </div>
                        <div class="site-name-slogan">        
                                <h2 class="site-name element-invisible"><a href="/" title="Home">Farmington Independent</a></h2>
                              </div>
          </div>
          </div>
</div><div class="grid-6 region region-masthead-first" id="region-masthead-first">
  <div class="region-inner region-masthead-first-inner">
    <div class="block block-search block-form block-search-form odd block-without-title" id="block-search-form">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <form action="/news/government-and-politics/4630378-rosemount-port-authority-debates-value-low-performing-retail" method="post" id="search-block-form" accept-charset="UTF-8"><div>  <div class="container-inline">
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_id" value="search_block_form" />
  </div>
</div></form>    </div>
  </div>
</div>  </div>
</div><div class="grid-6 region region-masthead-second fcc-omega-masthead-second last-omega-col" id="region-masthead-second">
  <div class="region-inner region-masthead-second-inner">
    <div class="block block-fcc-weather block-fcc-weather-masthead-wrapper block-fcc-weather-fcc-weather-masthead-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-masthead-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='fcc_weather_masthead_wrapper'></div>    </div>
  </div>
</div><div class="block block-fcc-advertising block-weather-sponsorship block-fcc-advertising-weather-sponsorship even block-without-title" id="block-fcc-advertising-weather-sponsorship">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='weather-sponsorship'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('weather-sponsorship');
          });
          jQuery(window).on('load', function() {
            googletag.pubads().refresh([window['weather_sponsorship']]);
          });
        </script>
      </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-menu-wrapper" class="zone-wrapper zone-menu-wrapper clearfix fcc-menu-wrapper">  
  <div id="zone-menu" class="zone zone-menu clearfix container-16">
    <div class="grid-16 region region-menu" id="region-menu">
  <div class="region-inner region-menu-inner">
        <div class="block block-fcc-custom-blocks block-doormat-menu block-fcc-custom-blocks-doormat-menu odd block-without-title" id="block-fcc-custom-blocks-doormat-menu">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="mobile-overlay"></div>
<div class="mobile-button-search">Search</div>
<div class="mobile-button-sections">Sections</div>

<div id="zone-menu-anchor"></div>

<div class="block-main-menu">
    <div class="block-inner clearfix">
        <ul class="menu">
            <li class='first leaf'><a href='/'>Home</a></li><li class='leaf logo'><a href='/'><img src='/sites/all/themes/farmingtonindependent_theme/logo.png' /></a></li><li class='leaf'><a href="/news" target="_self">news</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/news/government-and-politics/4630378-rosemount-port-authority-debates-value-low-performing-retail'>Rosemount Port Authority debates value of low performing Retail Strategies </a></li><li><a href='/news/4630024-goats-chomp-invasive-species-city-parks'>Goats chomp on invasive species at city parks</a></li><li><a href='/news/crime-and-courts/4630585-minnesota-woman-asks-pardons-board-help-her-avoid-persecution-home'>Minnesota woman asks pardons board to help her avoid persecution in home country</a></li><li><a href='/news/4630028-rosemount-rec-center-proposal-builds-steam'>Rosemount rec center proposal builds steam</a></li><li><a href='/news/government-and-politics/4629457-county-hopes-federal-grant-will-spur-development'>County hopes federal grant will spur development</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/news/crime-and-courts" target="_self">crime and courts</a></li><li><a href="/tags/government" target="_self">government</a></li><li><a href="/news/education" target="_self">education</a></li><li><a href="/tags/politics" target="_self">politics</a></li><li><a href="/tags/region" target="_self">region</a></li><li><a href="/news/accidents" target="_self">accidents</a></li></ul></div></div></li><li class='leaf'><a href="/sports" target="_self">sports</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/sports/other/4630083-where-are-they-now'>Where are they now?</a></li><li><a href='/sports/golf/4628974-farmington-boys-golf-takes-fifth-section-tournament'>Farmington boys&#039; golf takes fifth at section tournament</a></li><li><a href='/sports/golf/4628445-farmington-girls-golf-has-best-sections-finish-2007'>Farmington girls&#039; golf has best sections finish since 2007</a></li><li><a href='/sports/golf/4627100-8th-annual-louis-schmitz-foundation-memorial-golf-classic-held-friday'>8th annual Louis Schmitz Foundation Memorial Golf Classic held Friday</a></li><li><a href='/sports/outdoors/4626404-farmington-high-school-fishing-team-starts-inaugural-season'>Farmington High School fishing team starts inaugural season</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/tags/high-school" target="_self">high school</a></li><li><a href="/tags/amateur" target="_self">amateur</a></li><li><a href="/sports/outdoors" target="_self">outdoors</a></li></ul></div></div></li><li class='leaf'><a href="/tags/life" target="_self">life</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/community/events/4352119-community-celebrates-patriotic-day'>Community celebrates Patriotic Day</a></li><li><a href='/community/events/4352558-tough-talk-out-open-authors-farmington-share-stories-living-minnesota'>Tough talk out in the open: Authors in Farmington share stories of living in Minnesota as minorities</a></li><li><a href='/lifestyle/health/4350254-health-briefs-community-conversation-gets-people-talking-about-mental'>Health briefs: Community Conversation gets people talking about mental health</a></li><li><a href='/entertainment/4346907-farmington-auto-repair-shop-doubles-art-gallery'>Farmington auto repair shop doubles as art gallery</a></li><li><a href='/community/events/4345947-plenty-see-and-spray-farmington-fire-department-holds-open-house'>Plenty to see and spray: Farmington Fire Department holds open house</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/tags/arts-and-entertainment" target="_self">arts and entertainment</a></li><li><a href="/tags/food" target="_self">food</a></li><li><a href="/tags/health" target="_self">health</a></li><li><a href="/tags/religion" target="_self">religion</a></li><li><a href="/tags/family" target="_self">family</a></li></ul></div></div></li><li class='leaf'><a href="/business" target="_self">Business</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/business/small-business/4627201-new-way-organize-method-organization-co-specializes-senior-move'>A new way to organize: Method Organization Co. specializes in senior move management </a></li><li><a href='/business/tourism/4628889-resorts-campgrounds-continue-disappear-minnesota-tourism-industry-could'>As resorts, campgrounds continue to disappear, Minnesota tourism industry could take a hit</a></li><li><a href='/business/manufacturing/4627200-here-there-akins-turn-family-business-passion'>From Here to There: The Akins turn the family business into a passion </a></li><li><a href='/business/retail/4627196-summer-jobs-how-teens-can-capitalize-tight-job-market'>Summer jobs: how teens can capitalize on the tight job market</a></li><li><a href='/business/small-business/4621634-pick-some-sweet-somethings-strawberries-season-starts-soon'>Pick some sweet somethings: Strawberries season starts soon</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/business/announcements" target="_self">Announcements</a></li><li><a href="https://classifieds2.forumcomm.com/fcccontent/WFCategoryClassification.aspx" target="_self">Place a Business Announcement</a></li></ul></div></div></li><li class='leaf'><a href="/tags/notices" target="_self">notices</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/community/legal-notices/4630672-probate-notice-john-j-lentsch-19ha-pr-19-446'>Probate Notice: John J. Lentsch 19HA-PR-19-446</a></li><li><a href='/community/legal-notices/4627988-assumed-name-notice-tcs-delivery'>Assumed Name Notice: TC&#039;s Delivery</a></li><li><a href='/community/legal-notices/4627986-assumed-name-tournesol-solutions'>Assumed Name Tournesol Solutions</a></li><li><a href='/community/legal-notices/4627985-notice-mortgage-foreclosure-jason-and-jamie-kormanik'>NOTICE OF MORTGAGE FORECLOSURE: Jason and Jamie Kormanik</a></li><li><a href='/community/legal-notices/4627987-empire-township-public-notice-proposals-auditing-financial'>EMPIRE TOWNSHIP Public Notice: Proposals-  Auditing Financial Statements</a></li></ul></div></div></li><li class='leaf'><a href="/obituaries" target="_self">obituaries</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/obituaries/4629402-harry-c-ross'>Harry C. Ross</a></li><li><a href='/obituaries/4623299-gary-martin'>Gary Martin</a></li><li><a href='/obituaries/4620217-marjorie-holt'>Marjorie Holt</a></li><li><a href='/obituaries/4612349-brett-ryan-urban'>Brett Ryan Urban</a></li><li><a href='/obituaries/4602310-arlene-d-sacks'>Arlene D. Sacks</a></li></ul></div></div></li><li class='leaf'><a href="/milestones" target="_self">milestones</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/milestones/4515587-george-phyllis-betzold'>George &amp; Phyllis Betzold</a></li><li><a href='/milestones/4511923-george-phyllis-betzold'>George &amp; Phyllis Betzold</a></li><li><a href='/milestones/4471478-fhs-class-1993'>FHS Class of 1993</a></li><li><a href='/milestones/4456963-sophia-ecklund-panyk'>Sophia Ecklund       Panyk</a></li><li><a href='/milestones/4450687-dr-alexandra-v-fromme'>Dr. Alexandra V. Fromme</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/milestones/anniversaries" target="_self">anniversaries</a></li><li><a href="/milestones/birthdays" target="_self">birthdays</a></li><li><a href="/milestones/engagements" target="_self">engagements</a></li><li><a href="/milestones/new-arrivals" target="_self">new arrivals</a></li><li><a href="/milestones/weddings" target="_self">weddings</a></li><li><a href="/milestones/other-celebrations" target="_self">other celebrations</a></li></ul></div></div></li><li class='leaf'><a href="/opinion" target="_self">opinion</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/opinion/editorials/4630363-editorial-grab-some-local-summer-fun'>Editorial: Grab some local summer fun</a></li><li><a href='/opinion/editorials/4627241-editorial-thunder-lightning-illegal-lightening-pocket'>Editorial: Thunder, lightning, illegal lightening of the pocket</a></li><li><a href='/opinion/editorials/4626145-editorial-swimming-proficiency-local-must'>Editorial: Swimming proficiency is a local &#039;must&#039; </a></li><li><a href='/letters/4625415-justin-olsen-cottage-grove-city-council'>Justin Olsen for Cottage Grove City Council</a></li><li><a href='/opinion/editorials/4621128-editorial-orange-cone-season-no-joke'>Editorial: Orange cone season is no joke</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/opinion/columns" target="_self">columns</a></li><li><a href="/opinion/letters" target="_self">letters</a></li><li><a href="/opinion/editorials" target="_self">editorials</a></li><li><a href="https://classifieds2.forumcomm.com/forumcele/WFCategoryClassification.aspx" target="_self">Submit a Political Letter</a></li></ul></div></div></li><li class='leaf no-doormat'><a href="/basic-page/3729449-magazine-rack" target="_self">Magazine Rack</a></li><li class='leaf no-doormat'><a href="https://en.calameo.com/read/000735261cd5e58060ce8" target="_self">Real Estate Showcase</a><div class='doormat-menu'><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="https://www.rivertownlistings.com/" target="_self">Real Estate Showcase Ad Submission</a></li><li><a href="https://en.calameo.com/read/000735261cd5e58060ce8" target="_self">Real Estate Showcase current ads</a></li></ul></div></div></li><li class='leaf no-doormat'><a href="https://local.farmingtonindependent.com/ads" target="_self">Print Ads</a></li>        </ul>
    </div>
</div>    </div>
  </div>
</div>  </div>
</div>
  </div>
</div>  
  <div id="zone-weather" class="zone zone-weather clearfix container-16">
    <div class="grid-16 region region-weather" id="region-weather">
  <div class="region-inner region-weather-inner">
    <div class="block block-fcc-weather block-fcc-weather-wrapper block-fcc-weather-fcc-weather-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div id="fcc_weather_wrapper" class="weather-forecast-container clearfix">
  <h2 class="hide-title">Weather Forecast</h2>
  <a href="javascript:void(0)" id="fcc_weather_close" class="fcc-weather-close">Close</a>
  <div class="weather-col-first">
    <ul class="quicktabs-tabs">
      <li class="first" id="fcc_weather_show_forecast_tab"><a href="javascript:void(0)" id="fcc_weather_show_forecast">Forecast</a></li>
      <li class="last" id="fcc_weather_show_radar_tab"><a href="javascript:void(0)" id="fcc_weather_show_radar">Radar</a></li>
    </ul>
  </div>

  <div class="weather-col weather-col-ad">
    <div class="weather-ad-wrapper">
          </div>
  </div>
</div>
    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-sliding-billboard" class="zone zone-sliding-billboard clearfix container-16">
    <div class="grid-16 region region-sliding-billboard" id="region-sliding-billboard">
  <div class="region-inner region-sliding-billboard-inner">
    <div class="block block-fcc-advertising block-top-leaderboard-ad block-fcc-advertising-top-leaderboard-ad odd block-without-title" id="block-fcc-advertising-top-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='top-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('top-leaderboard-ad');
          });
          jQuery(window).on('load', function() {
            refreshBid('top-leaderboard-ad', 'top_leaderboard_ad');
          });
        </script>
      </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</header>    
          <section id="section-content" class="section section-content">
    
  <div id="zone-alert" class="zone zone-alert clearfix container-16">
    <div class="grid-16 region region-alert" id="region-alert">
  <div class="region-inner region-alert-inner">
    <div class="block block-fcc-live-video block-fcc-live-video-ajax-container block-fcc-live-video-fcc-live-video-ajax-container odd block-without-title" id="block-fcc-live-video-fcc-live-video-ajax-container">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="fcc-live-video-ajax-container"></div>    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-main-content" class="zone zone-main-content clearfix container-16">
    <div class="grid-10 region region-content fcc-omega-content first-omega-col" id="region-content">
  <div class="region-inner region-content-inner">
    <a id="main-content"></a>
                                                        <ul class="action-links"></ul>    <div class="block block-system block-main block-system-main odd block-without-title" id="block-system-main">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <!-- Schema.org Tags --> <div itemscope itemtype='http://schema.org/NewsArticle'> <meta itemprop='articleSection' content="News "> <meta itemprop='dateline' content="Red Wing,Minnesota 55066"> <meta itemprop='articleBody' content="&lt;p&gt;Rosemount Port Authority debated the value of continuing to pay for the annual membership of Retail Strategies — a firm that assists cities in the pursuit of retail opportunities — at its June 18 meeting.&lt;/p&gt;&lt;p&gt;The firm communicates to companies that may wish to locate or develop a new business or industry about the benefits of Rosemount. The firm deals with national franchise chains and serves as a connection between the community and property owners.&lt;/p&gt;&lt;p&gt;Rosemount Mayor Bill Droste said the firm bridges gaps as far as certain types of restaurants and businesses looking for a certain demographic.&lt;/p&gt;&lt;p class=&quot;subhead&quot;&gt;Value of Retail Strategies&lt;/p&gt;&lt;p&gt;Retail Strategies recently sent out a packet to Rosemount City Council and city staff.&lt;/p&gt;&lt;p&gt;&quot;There is not a lot of substantive information related to Rosemount, so we are expecting on the next month a more detailed review of Rosemount and their visit,&quot; said Kim Lindquist, community development director for the city of Rosemount.&lt;/p&gt;&lt;p&gt;Rosemount Port Authority chair Jeff Weisensel expressed his concern and disappointment if the packet was geared for Rosemount. He said he sent an email to a representative with Retail Strategies sharing he was looking for more communication about responses to business contacts.&lt;/p&gt;&lt;p&gt;Weisensel said the city is interested in bringing a craft brewery or a barbecue restaurant to Rosemount.&lt;/p&gt;&lt;p&gt;&quot;They contacted us to say it was going to be a little late and I was expecting a little more,&quot; Lindquist said.&lt;/p&gt;&lt;p&gt;&quot;At one time we looked at Retail Strategies versus a position (city job) and they obviously have some different goals and we can talk about that but we need to make sure to pay attention to the deadline,&quot; Lindquist said at the Port Authority meeting.&lt;/p&gt;&lt;p&gt;The third year of the Retail Strategies contract would cost $40,000.&lt;/p&gt;&lt;p&gt;&quot;I am not sure we are getting our bang for our buck here,&quot; City Council member Heidi Freske said.&lt;/p&gt;&lt;p class=&quot;subhead&quot;&gt;Chicken and egg economic development&lt;/p&gt;&lt;p&gt;Rosemount City Administrator Logan Martin said he is not aware if there is a specific metric to measure the performance of Retail Strategies.&lt;/p&gt;&lt;p&gt;&quot;It is kind of a chicken and egg economic development thing, and so Jersey Mikes and Noodles were contacted by Retail Strategies but did the broker already know those guys?&quot; Martin said.&lt;/p&gt;&lt;p&gt;Retail Strategies could have played a role to land the two fast food restaurant deals, but probably not a substantial role, Martin said.&lt;/p&gt;&lt;p&gt;&quot;It is contacts and introductions that we haven't done and part of that will change with the hiring of the new person and that person does not walk in with the same contacts that Retail Strategies has,&quot; Martin said.&lt;/p&gt;&lt;p&gt;&quot;The metric was if they (Retail Strategies) brought in one (new business), then that would generate the property tax they would bring in for a period of time and that would offset the fees, so it was like a zero sum game and if they (Retail Strategies) were able to bring in $50,000 in tax revenue and then it would have been fine,&quot; Weisensel said.&lt;/p&gt;&lt;p&gt;During the last conversation the city conducted with Retail Strategies, the city stressed gratitude on filling the spaces, but Lindquist said she communicated how the city is really focused on new construction or building that will bring new retail to the city.&lt;/p&gt;&lt;p class=&quot;subhead&quot;&gt;Evaluate performance&lt;/p&gt;&lt;p&gt;&quot;I might suggest we treat this like a poor performing employee and that we are not exactly thrilled with their performance,&quot; said City Council member Paul Essler. &quot;For that $40,000, we can send them a message that between now and December we do need to have access and what are the KPIs (key performance indicators), so we know if they are being successful or not.&quot;&lt;/p&gt;&lt;p&gt;Essler said he is not in favor of supporting Retail Strategies in December.&lt;/p&gt;&lt;p&gt;&quot;I do think we owe it to them to set up the expectation and let them know we are considering whether to renew or not,&quot; Essler added.&lt;/p&gt;&lt;p&gt;Weisensel said the city needs to proceed with caution because this type of networking and business recruitment takes time to build relationships.&lt;/p&gt;&lt;p&gt;Droste said during the council's goal session, there was discussion about what service they are giving to residents and the council decided to wait six months to talk about the progress.&lt;/p&gt;&lt;p&gt;&quot;Now we are halfway through the year and if we don't have a project on line, then we are going to have nothing built next year besides our city community center and downtown, we are sort of driving it,&quot; Droste said.&lt;/p&gt;&lt;p&gt;If the city is not working with someone in the next three months, then there will not be anything new on the table except housing, Droste said.&lt;/p&gt;&lt;p&gt;Essler said before the city hires a new economic development coordinator, the city staff needs to work to define the KPI to measure progress.&lt;/p&gt;&lt;p&gt;&quot;There are going to be efforts and there are going to be results, and what we are saying is the results may take time but we need to know what we expect those results to be,&quot; Essler said. &quot;I would ask staff what you do think are the right metrics and then we can communicate that out in front with candidates.&quot;&lt;/p&gt;&lt;p&gt;Martin said Rosemount Port Authority's budget will be finalized in December and if the group decides, the payment of Retail Strategies can be pulled out.&lt;/p&gt;"> <span itemprop='headline'> <meta itemprop='headline' content="Rosemount Port Authority debates value of low performing Retail Strategies "> <meta itemprop='author' content="Kara Hildreth"> <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"> <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <meta itemprop="url" content="https://www.farmingtonindependent.com/sites/all/themes/fcc_basetheme/images/social_default_image.png"> <meta itemprop="width" content="128"> <meta itemprop="height" content="128"> </div> <meta itemprop="name" content="Forum Communications Company"> </div> <meta itemprop='datePublished' content="2019-06-28T05:00:00"> <meta itemprop='dateModified' content="2019-06-28T05:00:57"> <link itemprop='mainEntityOfPage' content="node/4630378"> </span> <span itemprop="image" itemscope itemtype="http://schema.org/ImageObject"> <meta itemprop="url" content="https://www.farmingtonindependent.com/sites/default/files/styles/square_300/public/field/image/meeting%20watch_72.jpg?itok=PaK-NBV4"> <meta itemprop="width" content="860"> <meta itemprop="height" content="484"> </span> <div itemscope itemtype='http://schema.org/CreativeWork' id='schemaorg-creative-work'> <meta itemprop='author' content="Kara Hildreth"> </div> <div itemscope itemtype='http://schema.org/Thing' id='schemaorg-name'> <meta itemprop='name' content="Rosemount Port Authority debates value of low performing Retail Strategies "> </div> <div itemscope itemtype='http://schema.org/PostalAddress' id='schemaorg-address'> <meta itemprop='addressLocality' content="Red Wing"> <meta itemprop='addressRegion' content="Minnesota"> <meta itemprop='streetAddress' content="2760 N Service Drive"> <meta itemprop='postalCode' content="55066"> </div> </div><div id='first-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('first-mobile-ad');
          });
          jQuery(window).on('load', function() {
            refreshBid('first-mobile-ad', 'first_mobile_ad');
          });
        </script>
        </div><h1 class='node-title'>Rosemount Port Authority debates value of low performing Retail Strategies </h1>
<div class='node-byline'>
  <span class='node-byline-author'>By <a href='/users/kara-hildreth'>Kara Hildreth</a></span>
  <span class='node-byline-time'> Today  at 5:00 a.m.</span>
  <!--Share buttons-->
  <div id="sticky-anchor"></div>
  <div id="sticky" class='node-share-buttons'>
    <div class="addthis_sharing_toolbox"></div>
  </div>
  </div><div class='node-image-wrapper large'><div style='position: relative;'><img class='node-image large' src='https://www.farmingtonindependent.com/sites/default/files/styles/16x9_620/public/field/image/meeting%20watch_72.jpg?itok=S8puwiR2' data-featherlight='https://www.farmingtonindependent.com/sites/default/files/styles/full_1000/public/field/image/meeting%20watch_72.jpg?itok=Dkugkk6V'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption image-caption-display'></span></div></div><style>.page-node div.article-slider ul li {display:block;} img.image-info {float: none; display: none !important;} div span.image-caption-display {display: inline-block; width: 100%;}</style><div class='node-body'><p>Rosemount Port Authority debated the value of continuing to pay for the annual membership of Retail Strategies — a firm that assists cities in the pursuit of retail opportunities — at its June 18 meeting.</p></div><div id='second-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('second-mobile-ad');
          });
          jQuery(window).on('load', function() {
            refreshBid('second-mobile-ad', 'second_mobile_ad');
          });
        </script>
        </div>    <script type="text/javascript">
        // Google Consumer Survey
        (function () {
            var ARTICLE_URL = window.location.href;
            var CONTENT_ID = 'everything';
            document.write(
                    '<scr' + 'ipt ' +
                    'src="//survey.g.doubleclick.net/survey?site=_xxmbsoibfj35ly7ss43jyayvwu' +
                    '&url=' + encodeURIComponent(ARTICLE_URL) +
                    (CONTENT_ID ? '&cid=' + encodeURIComponent(CONTENT_ID) : '') +
                    '&random=' + (new Date).getTime() +
                    '" type="text/javascript">' + '\x3C/scr' + 'ipt>');
        })();
    </script>
<div class='p402_premium'><div class='node-body'><p>The firm communicates to companies that may wish to locate or develop a new business or industry about the benefits of Rosemount. The firm deals with national franchise chains and serves as a connection between the community and property owners.</p><p>Rosemount Mayor Bill Droste said the firm bridges gaps as far as certain types of restaurants and businesses looking for a certain demographic.</p><p class="subhead">Value of Retail Strategies</p><p>Retail Strategies recently sent out a packet to Rosemount City Council and city staff.</p><div id='jobsHQ-hotjobs-single-0' class='jobsHQ-hotjobs-single'></div><p>"There is not a lot of substantive information related to Rosemount, so we are expecting on the next month a more detailed review of Rosemount and their visit," said Kim Lindquist, community development director for the city of Rosemount.</p><p>Rosemount Port Authority chair Jeff Weisensel expressed his concern and disappointment if the packet was geared for Rosemount. He said he sent an email to a representative with Retail Strategies sharing he was looking for more communication about responses to business contacts.</p><p>Weisensel said the city is interested in bringing a craft brewery or a barbecue restaurant to Rosemount.</p><p>"They contacted us to say it was going to be a little late and I was expecting a little more," Lindquist said.</p><div id='jobsHQ-hotjobs-single-1' class='jobsHQ-hotjobs-single'></div><p>"At one time we looked at Retail Strategies versus a position (city job) and they obviously have some different goals and we can talk about that but we need to make sure to pay attention to the deadline," Lindquist said at the Port Authority meeting.</p><p>The third year of the Retail Strategies contract would cost $40,000.</p><p>"I am not sure we are getting our bang for our buck here," City Council member Heidi Freske said.</p><p class="subhead">Chicken and egg economic development</p><p>Rosemount City Administrator Logan Martin said he is not aware if there is a specific metric to measure the performance of Retail Strategies.</p><p>"It is kind of a chicken and egg economic development thing, and so Jersey Mikes and Noodles were contacted by Retail Strategies but did the broker already know those guys?" Martin said.</p><p>Retail Strategies could have played a role to land the two fast food restaurant deals, but probably not a substantial role, Martin said.</p><div id='jobsHQ-hotjobs-single-2' class='jobsHQ-hotjobs-single'></div><p>"It is contacts and introductions that we haven't done and part of that will change with the hiring of the new person and that person does not walk in with the same contacts that Retail Strategies has," Martin said.</p><div id='mid-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('mid-leaderboard-ad');
          });
          jQuery(window).ready(function() {
            refreshBid('mid-leaderboard-ad', 'mid_leaderboard_ad');
          });
        </script>
        </div><p>"The metric was if they (Retail Strategies) brought in one (new business), then that would generate the property tax they would bring in for a period of time and that would offset the fees, so it was like a zero sum game and if they (Retail Strategies) were able to bring in $50,000 in tax revenue and then it would have been fine," Weisensel said.</p><p>During the last conversation the city conducted with Retail Strategies, the city stressed gratitude on filling the spaces, but Lindquist said she communicated how the city is really focused on new construction or building that will bring new retail to the city.</p><p class="subhead">Evaluate performance</p><p>"I might suggest we treat this like a poor performing employee and that we are not exactly thrilled with their performance," said City Council member Paul Essler. "For that $40,000, we can send them a message that between now and December we do need to have access and what are the KPIs (key performance indicators), so we know if they are being successful or not."</p><p>Essler said he is not in favor of supporting Retail Strategies in December.</p><p>"I do think we owe it to them to set up the expectation and let them know we are considering whether to renew or not," Essler added.</p><p>Weisensel said the city needs to proceed with caution because this type of networking and business recruitment takes time to build relationships.</p><p>Droste said during the council's goal session, there was discussion about what service they are giving to residents and the council decided to wait six months to talk about the progress.</p><p>"Now we are halfway through the year and if we don't have a project on line, then we are going to have nothing built next year besides our city community center and downtown, we are sort of driving it," Droste said.</p><p>If the city is not working with someone in the next three months, then there will not be anything new on the table except housing, Droste said.</p><p>Essler said before the city hires a new economic development coordinator, the city staff needs to work to define the KPI to measure progress.</p><p>"There are going to be efforts and there are going to be results, and what we are saying is the results may take time but we need to know what we expect those results to be," Essler said. "I would ask staff what you do think are the right metrics and then we can communicate that out in front with candidates."</p><p>Martin said Rosemount Port Authority's budget will be finalized in December and if the group decides, the payment of Retail Strategies can be pulled out.</p></div><div style='clear:both;'></div></div><script type="text/javascript">try {_402_Show();} catch (e) {}</script>
<div class='recommended node-ad-mobile nocontent'></div><script type='text/javascript'>
				jQuery('.recommended.node-ad-mobile a').on('click', function() {
					ga('send', 'event', 'Recommended', 'click', 'recommended-click');
					ga('combinedSites.send', 'event', 'Recommended', 'click', 'recommended-click');
				});
			</script><script type='text/javascript'>
    jQuery('.recommended.node-ad-mobile a.with-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click with img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click with img', 'recommended-click');
    });

    jQuery('.recommended.node-ad-mobile a.without-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click without img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click without img', 'recommended-click');
    });
  </script><div id='third-mobile-ad-container'>
        <div id='third-mobile-ad' class='mobile-ad'>
          <script type='text/javascript'>
            googletag.cmd.push(function() {
              googletag.display('third-mobile-ad');
            });
            // Pass in the slot name for the ad
            jQuery(window).on('load', function() {
              jQuery('#third-mobile-ad-container').lazyload('third-mobile-ad');
            });
          </script>
          </div>
        </div><div class='node-related-topics clearfix'><span class='label'>Explore related topics:</span><a class='topic category' href='//www.farmingtonindependent.com/taxonomy/term/1'>News</a><a class='topic category' href='//www.farmingtonindependent.com/taxonomy/term/402687'>government and politics</a><a class='topic tag' href='//www.farmingtonindependent.com/taxonomy/term/2597'>Rosemount</a><a class='topic tag' href='//www.farmingtonindependent.com/taxonomy/term/458859'>Rosemount Port Authority</a><a class='topic tag' href='//www.farmingtonindependent.com/taxonomy/term/479733'>Retail Strategies</a></div><div id='ad-content-distribution'></div><div id='fourth-mobile-ad-container'>
        <div id='fourth-mobile-ad' class='mobile-ad'>
          <script type='text/javascript'>
            googletag.cmd.push(function() {
              googletag.display('fourth-mobile-ad');
            });
            // Pass in the slot name for the ad
            jQuery(window).on('load', function() {
              jQuery('#fourth-mobile-ad-container').lazyload('fourth-mobile-ad');
            });
          </script>
          </div>
        </div><script type='text/javascript'>
  ga('send', 'event', 'article', 'length', 'paragraphs',30);
  ga('send', 'event', 'article', 'paragraphs', '30');
  ga('send', 'event', 'article', 'length', 'characters',5319);
  ga('send', 'event', 'article', 'age', 'Less than 12 hours');
  ga('send', 'event', 'article', 'age', 'interval',11872);

  // Combined Sites
  ga('combinedSites.send', 'event', 'article', 'length', 'paragraphs',30);
  ga('combinedSites.send', 'event', 'article', 'paragraphs', '30');
  ga('combinedSites.send', 'event', 'article', 'length', 'characters',5319);
  ga('combinedSites.send', 'event', 'article', 'age', 'Less than 12 hours');
  ga('combinedSites.send', 'event', 'article', 'age', 'interval',11872);
</script>
    </div>
  </div>
</div>          </div>
</div>
<aside class="grid-6 region region-sidebar-first  fcc-omega-sidebar last-omega-col" id="region-sidebar-first">
  <div class="region-inner region-sidebar-first-inner">
    <div class="block block-fcc-advertising block-origami-ad block-fcc-advertising-origami-ad odd block-without-title" id="block-fcc-advertising-origami-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div id="origami-ad-container"></div>

  <script id="origami-ad-widget" src="https://origami.secure.ownlocal.com/origami-widget.js" data-partner-id="43d9e0a3-0eb4-4edf-98c7-dc9da141f353">
  </script>
    </div>
  </div>
</div><div class="block block-fcc-advertising block-first-sidebar-ad block-fcc-advertising-first-sidebar-ad even block-without-title" id="block-fcc-advertising-first-sidebar-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='first-sidebar-ad-container'>
        <div id='first-sidebar-ad'>
          <script>
            googletag.cmd.push(function() {
              googletag.display('first-sidebar-ad');
            });
            jQuery(window).on('load', function() {
              refreshBid('first-sidebar-ad', 'first_sidebar_ad');
            });
          </script>
        </div>
      </div>    </div>
  </div>
</div><div class="block block-fcc-custom-blocks block-trending-latest block-fcc-custom-blocks-trending-latest odd block-without-title" id="block-fcc-custom-blocks-trending-latest">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="space-eater latest-trending nocontent">
    <div class="select-homepage">
    <a class="active latest" href="/latest">Latest</a>
  </div>
  <div class="space-eater-section fcc-latest">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/news/government-and-politics/4630378-rosemount-port-authority-debates-value-low-performing-retail">Rosemount Port Authority debates value of low performing Retail Strategies <span class='latest-date'>3 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/opinion/editorials/4630363-editorial-grab-some-local-summer-fun">Editorial: Grab some local summer fun<span class='latest-date'>20 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/lifestyle/travel/4630400-101-things-do-cowling-arboretum-carleton-college">101 Things To Do: Cowling Arboretum at Carleton College<span class='latest-date'>21 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/community/events/4630866-turkey-farm-holds-tours-july-13-cannon-falls">Turkey farm holds tours July 13 in Cannon Falls<span class='latest-date'>23 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/news/4630024-goats-chomp-invasive-species-city-parks">Goats chomp on invasive species at city parks<span class='latest-date'>1 day ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-5">
        <div class="space-eater-headline class-14px"><a href="/news/crime-and-courts/4630585-minnesota-woman-asks-pardons-board-help-her-avoid-persecution-home">Minnesota woman asks pardons board to help her avoid persecution in home country<span class='latest-date'>1 day ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-6">
        <div class="space-eater-headline class-14px"><a href="/lifestyle/health/4630449-former-addict-opens-her-heart-and-home-moms-recovery">Former addict opens her heart and a home for moms in recovery<span class='latest-date'>1 day ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-7">
        <div class="space-eater-headline class-14px"><a href="/sports/other/4630083-where-are-they-now">Where are they now?<span class='latest-date'>2 days ago</span></a></div>
      </div>
        <a class="more" href="/latest">more <span class="arrow">〉</span></a>
</div></div>
    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-jobshq-widget block-boxes-jobshq-widget even block-without-title" id="block-boxes-jobshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-jobshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="jobs_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-carshq-widget block-boxes-carshq-widget odd block-without-title" id="block-boxes-carshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-carshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="carsHQ_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-apartmentshq-widget block-boxes-apartmentshq-widget even block-without-title" id="block-boxes-apartmentshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-apartmentshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="apartments_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div>  </div>
</aside>  </div>
  
  <div id="zone-bottom-leaderboard" class="zone zone-bottom-leaderboard clearfix container-16">
    <div class="grid-16 region region-bottom-leaderboard" id="region-bottom-leaderboard">
  <div class="region-inner region-bottom-leaderboard-inner">
    <div class="block block-fcc-advertising block-bottom-leaderboard-ad block-fcc-advertising-bottom-leaderboard-ad odd block-without-title" id="block-fcc-advertising-bottom-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <script>
jQuery(document).ready(function() {
  // This will fire when document is ready:
  jQuery(window).resize(function() {
      // This will fire each time the window is resized:
    
      if(jQuery(window).width() < 480) {
        if(jQuery('#origami_mobile_widget').is(':empty')){
          var script = document.createElement("script");
          script.setAttribute("charset", "UTF-8");
          script.setAttribute("src", "https://origami.secure.ownlocal.com/origami-widget.js");
          script.setAttribute("id", "origami-ad-widget");
          script.setAttribute("data-partner-id", "43d9e0a3-0eb4-4edf-98c7-dc9da141f353");
          script.setAttribute("data-ad-container-ids", "origami-ad-container2");
          script.setAttribute("type", "text/javascript");
          var head = document.getElementsByTagName("head")[0];
          head.appendChild(script);
          var origami = jQuery('<div></div>').attr("id", "origami-ad-container2");
          jQuery('#origami_mobile_widget').append(origami);
        }
      }
      else{ 
        jQuery('#origami_mobile_widget').empty();
      }
  }).resize(); // This will simulate a resize to trigger the initial run.
});
</script>
<div id="origami_mobile_widget" style="width: 300px; margin: 30px auto 10px;"></div>


<div id='bottom-leaderboard-ad-container'>
      <div id='bottom-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
              googletag.display('bottom-leaderboard-ad');
          });
          // Pass in the slot name for the ad
          jQuery(window).on('load', function() {
            jQuery('#bottom-leaderboard-ad-container').lazyload('bottom-leaderboard-ad');
          });
        </script>
      </div>
    </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</section>    
  
      <footer id="section-footer" class="section section-footer">
  <div id="zone-postscript-wrapper" class="zone-wrapper zone-postscript-wrapper clearfix">  
  <div id="zone-postscript" class="zone zone-postscript clearfix container-16">
    <div class="grid-4 fcc-omega-postscript first-omega-col region region-postscript-first">
  <section class="block">
    <h2>Account</h2>
    <ul>
      <li><a href="/user" title="">Manage My Account</a></li>
      <li><a href='https://newspaper.forumcomm.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=RFA' title=''>Manage Home Delivery</a></li>      <li><a href="/privacy" title="">Privacy Policy</a></li>
      <li><a href="/terms" title="">Terms and Conditions</a></li>
    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript region region-postscript-second">
  <section class="block">
    <h2>Newspaper</h2>
    <ul>
      <li><a href="https://allaccess.forumcomm.com/allaccess/farmingtonindependent" title="">Subscribe to the Paper</a></li><li><a href="http://digital.olivesoftware.com/Olive/ODN/IndependentTownPages/Default.aspx" title="Access E-Paper">Access E-Paper</a></li>      <li><a href="http://www.rivertownmultimedia.com">Advertise with us</a></li>    </ul>
  </section>
</div>
<div class="grid-4 fcc-omega-postscript region region-postscript-third">
  <section class="block">
    <h2>Contact</h2>
    <ul>
      <li><a href="/contact-us" title="">Contact Us</a></li>
      <li><a href="mailto:customerservice+farmingtonindependent.com@forumcomm.com" title="">Get Website Help</a></li>
      <li><a href="http://www.forumcomm.com/careers/" title="">Work With Us</a></li>
    </ul>
  </section>
</div>
<div class="grid-4 fcc-omega-postscript last-omega-col region region-postscript-fourth">
  <section class="block">
    <h2>More</h2>
    <ul>
      <li><a href="//www.jobshq.com" target="_blank" title="JobsHQ">JobsHQ</a></li>
      <li><a href="http://www.carshq.com" target="_blank" title="CarsHQ">CarsHQ</a></li>
      <li><a href="//www.homeshq.com" target="_blank" title="HomesHQ">HomesHQ</a></li>
      <li><a href="http://www.northlandoutdoors.com" target="_blank" title="Northland Outdoors">Northland Outdoors</a></li>
      <li><a href="//www.agweek.com" target="_blank" title="Agweek">Agweek</a></li>
      <li><a href="//impact.areavoices.com" target="_blank" title="Impact Magazine">Impact Magazine</a></li>
    </ul>
  </section>
</div><div class="grid-16 region region-postscript-fifth">
  <section class="block block-menu block-menu-footer-social-menu block-menu-menu-footer-social-menu odd" id="block-menu-menu-footer-social-menu">
    <h2>Social</h2>
    <ul>
      <li><a href="http://www.areavoices.com" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/areavoices-social.png" /> Areavoices</a></li>
      <li><a href="https://www.twitter.com/farmington" title="Find us on Twitter"><img alt="Find us on Twitter" src="/sites/all/themes/fcc_basetheme/images/icons/twitter-social.png" /> Twitter</a></li><li><a href="https://www.facebook.com/farmingtonindependent" title="Find us on Facebook"><img alt="Find us on Facebook" src="/sites/all/themes/fcc_basetheme/images/icons/fb-social.png" /> Facebook</a></li><li><a href="https://plus.google.com/102646955521009741833/" title="Find us on Google+" rel="publisher"><img alt="Find us on Google+" src="/sites/all/themes/fcc_basetheme/images/icons/google-social.png" /> Google+</a></li>      <li><a href="/latest/rss/" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/rss-social.png" /> RSS Feeds</a></li>
    </ul>
  </section>
</div>  </div>
</div><div id="zone-footer-wrapper" class="zone-wrapper zone-footer-wrapper clearfix">  
  <div id="zone-footer" class="zone zone-footer clearfix container-16">
    <div class="grid-16 region region-footer" id="region-footer">
  <div class="region-inner region-footer-inner">
    <div class="block block-fcc-custom-blocks block-footer-site-info block-fcc-custom-blocks-footer-site-info odd block-without-title" id="block-fcc-custom-blocks-footer-site-info">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div class="vcard footer-contact">
  <div hidden="hidden">
    <div class="fn" style="display:none"> <a href="http://www.forumcomm.com/">Forum Communications Company</a></div>
    <span class="version" hidden="hidden" style="display:none">3.0</span>

    <div class="n listed-fields" style="display:none"> 
      <span class="given-name">&copy; Farmington Independent</span>
      <span class="family-name">Forum Communications Company</span>
    </div>

    <span class="email" style="display:none"> <a href="websitesupport@forumcomm.com">websitesupport@forumcomm.com</a></span>
    <div class="org">&copy; Farmington Independent</div> and
    <div class="role"><a href="http://www.forumcomm.com/">Forum Communications Company</a></div><br />

    <div class="adr listed-fields">
      <div class="street-address listed-fields">2760 N Service Drive</div>
      <span class="locality">Red Wing</span>, 
      <span class="region">Minnesota</span> 
      <span class="postal-code">55066</span>
    </div>

    Call us at <div class="tel">800-535-1660</div>
  </div>
</div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div></footer>  </div><div class="region region-page-bottom" id="region-page-bottom">
  <div class="region-inner region-page-bottom-inner">
    <div><a rel="nofollow" href="http://www.fccnn.com/newspaper.php"></a></div>  </div>
</div><script type="text/javascript" defer="defer" src="https://tracking.fccinteractive.com/tracker.js"></script>
<script type="text/javascript" defer="defer" src="https://tracking.fccinteractive.com/recommendationTracker.js"></script>
<script type="text/javascript" src="https://www.farmingtonindependent.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat_config.min.js?ptakau"></script>
<script type="text/javascript" src="https://www.farmingtonindependent.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat.min.js?ptakau"></script>
<script type="text/javascript" src="https://i.simpli.fi/dpx.js?cid=4004&amp;m=1"></script>
<script type="text/javascript" src="https://widgets.stagingjobshq.com/dist/loadJobsHQ.js"></script>
<script type="text/javascript" src="https://www.farmingtonindependent.com/sites/all/themes/fcc_basetheme/js/min/widgets-page.min.js?ptakau"></script>
<script type="text/javascript" src="https://www.farmingtonindependent.com/sites/default/files/js/js_JozVjTMXs55bUfFMpJpqqcKwp4OKeoevi65GD95_4ys.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery(document).ready(function(){addthis.init()});
//--><!]]>
</script>
<script type="text/javascript" src="https://www.farmingtonindependent.com/sites/default/files/js/js_jNw4EtyrzIApV82kEWjNIwPts-FQ67yNMAmIDs7C-NE.js"></script>
<script type="text/javascript" src="https://www.farmingtonindependent.com/sites/all/themes/fcc_basetheme/js/min/widgets-html.min.js?ptakau"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if (jQuery(window).width() <= 728) {
    jQuery('#boxes-box-hq_widgets').remove();
    jQuery('div.spingo-widget').remove();
    }
//--><!]]>
</script>
<script type="text/javascript" src="https://www.farmingtonindependent.com/sites/all/themes/fcc_basetheme/js/min/clicktracking-global.min.js?ptakau"></script>
<script type="text/javascript" src="https://www.farmingtonindependent.com/sites/default/files/js/js_s6x42LSxRLi0Ub3S3e7HL1kmAtzsVGIyuWWtC6hytII.js"></script>

    <div id='in-page-ad'>
          <script>
            googletag.cmd.push(function() {
              googletag.display('in-page-ad');
            });
            jQuery(window).on('load', function() {
              googletag.pubads().refresh([window['in_page_ad']]);
            });
          </script>
        </div>  <script type='text/javascript'>
    var axel = Math.random() + '';
    var a = axel * 10000000000000;
    document.write('<img src="https://pubads.g.doubleclick.net/activity;dc_iu=/7021/DFPAudiencePixel;ord=' + a + ';dc_seg=757965564?" width=1 height=1 border=0/>');
  </script>
  <noscript>
    <img src="https://pubads.g.doubleclick.net/activity;dc_iu=/7021/DFPAudiencePixel;ord=1;dc_seg=757965564?" width=1 height=1 border=0/>
  </noscript>
  </body>
</html>
